RIP…JDK 1.4

3

Ok, I’m a little early. In one month on Halloween eve, JDK 1.4 will officially enter End of Service Life (EOSL) as part of the Sun end of life policy. JDK 1.4 was born in February of 2002 and has lived a long and successful life, probably one of the longest-lived and most widely-used Java releases to date due to fear of JDK 1.5.

Remember February 2002? 9/11 was still fresh and raw. Winter Olympics were happening in Utah. The Rams were narrowly defeated by the Patriots in the Super Bowl. And of course JDK 1.4 was released. As far as Java upgrades go, it was in the fast and easy upgrade camp. Some new and useful features (assert, regex, NIO, exception chaining) and some dogs (java logging). Other than the new assert keyword, most code ported up just fine.

So, what does EOSL mean exactly?

Honestly, that’s not precisely clear to me, but based on the rest of the policy, it seems to me like free support and updates stop. You can of course buy “retirement support” for the Java SE for Business release program and that is available for another 10 years.

If you look at what’s available for JDK 1.3 (obviously well into an end of life program that’s defined a little differently), you can see that there were new patch revs of JDK 1.3 released this year and last with updated time zone rules, so they still seem to be doing that. But presumably no bug fixes or other work is going into this release.

Based on my poll earlier this summer, there are still a lot of people using JDK 1.4 in production. I’m not sure how widely known it is that official free support for JDK 1.4 is at an end.

You may also have caught that next year on Halloween, JDK 1.5 enters EOSL! Start your planning now…

Comments

3 Responses to “RIP…JDK 1.4”
  1. Neal Gafter says:

    The scariest thing will be when JDK6 support ends and there is no JDK7 in sight.

  2. Luckily IBM will make sure that we can enjoy Java 1.4 for many years to come. Websphere 6.1 requires Java 1.5 and has been released 2 years ago, but a lot of customers are still running 6.0 or older and forcing us to deal with Java 1.4.

  3. The main effect of EOSL in my experience is when legislatures around the world decide to tweak their daylight savings time rules.